Web Analytics Made Easy -
StatCounter FF6 Doesn't Upload Files - CodingForum

Announcement

Collapse
No announcement yet.

FF6 Doesn't Upload Files

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • FF6 Doesn't Upload Files

    This form doesn't even upload an image in firefox6

    PHP Code:
    <form name='adminList' action='actions/tryupdateitem.php' method='post' enctype='mutlipart/form-data'>    
        <
    input type='hidden' name='table' value='images'>        
        <
    input type='hidden' name='id' value='56'>    
        <
    input type='hidden' name='xhashxtagx' value=''>
        <
    table id='itemTable' width='50%'><tbody><tr><td>categoryId</td><td><select name='categoryId'><option value='1' >Project Floorplans</option><option value='2' >General</option><option value='3' >Slideshow</option><option value='4' >Project Elevations</option><option value='5' >Project Photos</option><option value='6' >Home Images</option><option value='7' >Home Elevations</option><option value='8' >Home Floorplans</option><option value='9' >Phase Images</option><option value='10' >Award Images</option><option value='11' >Association Images</option><option value='12' SELECTED>Gallery</option><option value='13' >Testimonial Images</option><option value='14' >Client Images</option><option value='15' >Process</option></select></td></tr><tr><td>title</td><td><input type='text' name='title' value='title'/></td></tr><tr><td>source</td><td>
            <
    input type='hidden' name='source' value='xcheckxfilex'>
            <
    img src='../images/uploaded/833056997507810apple.jpg'/>
            <
    br/>
            
    Upload New Image: <input type='file' name='test'>
            </
    td></tr></tbody>
        </
    table>
        <
    div id='listFooter'>
            <
    button type='button' class='btn'>Update</button>
        </
    div>
    </
    form
    print_r($_FILES);

    Show nothing. Am I missing something?

  • #2
    Shouldn't you be using <input type="submit" value="Update"> ?
    "Tango says double quotes with a single ( ' ) quote in the middle"
    '$Name says single quotes with a double ( " ) quote in the middle'
    "Tango says double quotes ( \" ) must escape a double quote"
    '$Name single quotes ( \' ) must escape a single quote'

    Comment


    • #3
      My button class checks and submits the form. It works great in chrome but the file never gets uploaded in FF. In chrome it takes a bit of time while it's uploading the file information but in FF6 it goes straight to the page and the $_FILES array is empty. I'm guessing it's not uploading the file for some reason

      Comment


      • #4
        Originally posted by groog View Post
        My button class checks and submits the form. It works great in chrome but the file never gets uploaded in FF. In chrome it takes a bit of time while it's uploading the file information but in FF6 it goes straight to the page and the $_FILES array is empty. I'm guessing it's not uploading the file for some reason
        Well, the code you posted by itself, which doesn't even contain any PHP, doesn't submit the form. So, it's hard to fault FF for the form not working based on this. Post everything that is needed to submit the form, or change your update button to an <input type="submit" value="Update" />

        Comment


        • #5
          Originally posted by groog View Post
          My button class checks and submits the form. It works great in chrome but the file never gets uploaded in FF. In chrome it takes a bit of time while it's uploading the file information but in FF6 it goes straight to the page and the $_FILES array is empty. I'm guessing it's not uploading the file for some reason
          As Inigoesdr says you either need to show more PHP handling code or change your button (which I've also suggested).

          Even with your current button I believe it should still be <input type="button" value="Upload">

          Not <button ..>
          "Tango says double quotes with a single ( ' ) quote in the middle"
          '$Name says single quotes with a double ( " ) quote in the middle'
          "Tango says double quotes ( \" ) must escape a double quote"
          '$Name single quotes ( \' ) must escape a single quote'

          Comment

          Working...
          X