Web Analytics Made Easy -
StatCounter Apache Question - CodingForum

Announcement

Collapse
No announcement yet.

Apache Question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Apache Question

    Hi guys,

    I'm a newbie at apache here.

    I've got my apache to work on the localhost, now i'd like to make my standalone computer available to the public internet.

    How do I do that? my friend doesnt use apache and his one is available to the public internet. And what I mean by that is that people can access his web server (that is on his computer) just by using his IPort.

    Thank you in advance for the help.

    Regards,

  • #2
    You need to configure a directory to be accessible to the public in the apache config file. I don't recall if the default config sets one up or not although it would make sense that it did.
    Spookster
    CodingForum Supreme Overlord
    All Hail Spookster

    Comment


    • #3
      Arent they the same folder for both localhost and public internet?

      I got it working for localhost already, just need to get public internet going.

      And also, do you mind being more specific as to which section of the config file do i need to edit etc.

      Thank.

      Comment


      • #4
        Originally posted by PenguinJr
        Arent they the same folder for both localhost and public internet?

        I got it working for localhost already, just need to get public internet going.

        And also, do you mind being more specific as to which section of the config file do i need to edit etc.

        Thank.
        Not necessarily. If you downloaded Apache from their website and installed it using the default http.conf file which is the config file you will be working with then you should have the document root set to allow public access. If you downloaded some ready made development package that included Apache then the author of that package may have removed that setting or modified it in some way.

        You should see something along these lines:

        PHP Code:

        <Directory "C:/Program Files/Apache Group/Apache/htdocs">

        #
        # This may also be "None", "All", or any combination of "Indexes",
        # "Includes", "FollowSymLinks", "ExecCGI", or "MultiViews".
        #
        # Note that "MultiViews" must be named *explicitly* --- "Options All"
        # doesn't give it to you.
        #
            
        Options Indexes FollowSymLinks MultiViews

        #
        # This controls which options the .htaccess files in directories can
        # override. Can also be "All", or any combination of "Options", "FileInfo", 
        # "AuthConfig", and "Limit"
        #
            
        AllowOverride None

        #
        # Controls who can get stuff from this server.
        #
            
        Order allow,deny
            Allow from all
        </Directory
        without all the comments it looks like so:

        PHP Code:

        <Directory "F:/Program Files/Apache Group/Apache/htdocs">
            
        Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow
        ,deny
            Allow from all
        </Directory
        You will likely have more than one that looks like that. This is how you can define certain features for specific directories.
        Spookster
        CodingForum Supreme Overlord
        All Hail Spookster

        Comment


        • #5
          Hm...

          I do have all that...

          but my localserver is still not available to the public internet.

          My friends cant access me by my http://myIP:80

          Only i can access http://myIP:80 or http://localhost

          This is weird and annoying >.<

          Comment


          • #6
            Do you have a firewall running?
            Spookster
            CodingForum Supreme Overlord
            All Hail Spookster

            Comment


            • #7
              Nope.. never liked firewall...

              Comment


              • #8
                Well firewalls are a good thing. This sounds suspiciously like a firewall problem. Are you sure there are no firewalls running? Are you running WinXP? It has a built in firewall program that may be running.
                Spookster
                CodingForum Supreme Overlord
                All Hail Spookster

                Comment


                • #9
                  yup i'm 100% sure there is no firewall running.

                  If you mean the default winxp firewall in the internet/network setting, i turned it off.

                  Hmm...

                  Are you sure thats all I need to have my computer available to the public internet?

                  Comment

                  Working...
                  X