Web Analytics Made Easy -
StatCounter Form Submit in NetScape - CodingForum

Announcement

Collapse
No announcement yet.

Form Submit in NetScape

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Form Submit in NetScape

    I know next to nothing about HTML and Javascript and such. I'm hoping this is the correct category! My question is this: I have a survey in one of my web pages. It consists of several radio buttons, drop-down lists, a text field, and a text area, followed by a "submit" button. Everything works fine in IE, but in NS the "submit" button is gone and the actual word "submit" in its place. Why? Are my tags incorrect? I used
    <button type="submit">Submit</button></form>
    after all my other form elements.

  • #2
    try this:

    <form ...>

    <input type="submit" name="submit" value="Submit it!!!">
    .
    .
    .
    </form>...

    Comment


    • #3
      OK, well now the button actually shows up, but there are still problems. Nothing happens when I click it in both IE and NS. The text on the button is the default "Submit Query."

      Comment


      • #4
        This sounds more like a general web design question than a JavaScript question. I will move this to post over.

        In the mean time, we will need to see the code you are using or a url where it is active in order to be of much help.

        Comment


        • #5
          OK. The page it's on is at http://www.dreamwater.net/pnnccsd/survey.html .

          Comment


          • #6
            First off I would change the submit buttob as amcs suggested. Secondly your form tag will never allow the form to be submitted:

            <FORM METHOD=POST ACTION="http://www.dreamwater.net/cgi-bin/user_formmail.cgi/english" onsubmit="return false;">

            Try changing the button and deleteing the onsubmit bit. I just changed them and sent a test survey. My 15 year old daughter who is a total animee freak took the survey so the answers are even real.

            Comment


            • #7
              Yay! It works now! Thank you so much, everyone. I really appreciate it.

              Comment

              Working...
              X